Missing TestBench classes after upgrading

Hi there,
after updating to Vaadin 7.7.3 are not found anymore these classes:


Here is my ivy.xml


<?xml version="1.0"?> <!DOCTYPE ivy-module [
<!ENTITY guava.version "19.0">


    <!-- Vaadin themes -->
    <dependency org="com.vaadin" name="vaadin-themes" rev="&vaadin.version;" />

    <!-- Push support -->
    <dependency org="com.vaadin" name="vaadin-push" rev="&vaadin.version;" />

    <!-- Servlet 3.0 API -->
    <dependency org="javax.servlet" name="javax.servlet-api" rev="3.0.1" conf="nodeploy->default" />

    <!-- TestBench 4 -->
    <dependency org="com.vaadin" name="vaadin-testbench-api" rev="latest.release" conf="nodeploy -> default" />

    <!-- Precompiled DefaultWidgetSet -->
    <dependency org="com.vaadin" name="vaadin-client-compiled"
        rev="&vaadin.version;" />

    <!-- Vaadin client side, needed for widget set compilation -->
    <dependency org="com.vaadin" name="vaadin-client" rev="&vaadin.version;"
         conf="widgetset-compile->default" />

    <!-- Compiler for custom widget sets. Should not be deployed -->
    <dependency org="com.vaadin" name="vaadin-client-compiler"
        rev="&vaadin.version;" conf="widgetset-compile->default" />
    <!-- Vaadin Maddon -->
    <dependency org="org.peimari" name="maddon" rev="1.21" />
    <!-- Google Guava -->
    <dependency org="com.google.guava" name="guava" rev="&guava.version;" />
    <!-- Google Analytics -->
    <dependency org="org.vaadin.addons" name="googleanalyticstracker" rev="2.1.0" />
    <!-- Jasper Reports -->
    <dependency org="net.sf.jasperreports" name="jasperreports" rev="6.2.0" conf="*->default" />
    <dependency org="net.sf.jasperreports" name="jasperreports-fonts" rev="6.0.0"/>
[/code]Here is my ivysettings.xml [code] <?xml version="1.0" encoding="UTF-8"?>
        <!-- Vaadin Add-on repository -->
        <ibiblio name="vaadin-addons" usepoms="true" m2compatible="true"
            root="http://maven.vaadin.com/vaadin-addons" />

        <!-- Vaadin snapshots repository -->
        <ibiblio name="vaadin-snapshots" usepoms="true" m2compatible="true"
            root="https://oss.sonatype.org/content/repositories/vaadin-snapshots" />
        <!-- Repository used for Vaadin modified smartsprites library -->
        <dual name="custom-smartsprites">
            <filesystem name="smartsprites-ivy">
                <ivy pattern="${basedir}/ivymodule/[module]

.xml" />

        <!-- Jasper Reports repository -->
        <ibiblio name="jaspersoft" m2compatible="true" root="http://jasperreports.sourceforge.net/maven2/"/>
        <!--<ibiblio name="jaspersoft-third-party" usepoms="true" m2compatible="true"
            root="http://jaspersoft.artifactoryonline.com/jaspersoft/third-party-ce-artifacts" />-->
    <!-- Vaadin patched SmartSprites -->
    <module organisation="com.carrotsearch" name="smartsprites"
        revision="0.2.3-itmill" resolver="custom-smartsprites" />

Hi Carmelo,

There was something fuzzy in the “latest.release” resolution, it’s already been fixed but will require cleaning ivy cache to work locally, if you’re using eclipse with some ivy plugin it should appear as “Ivy / Clean cache” in context menu.

Apart from that, I’d recommend you to use same vaadin.version property for vaadin-testbench-api. It would look like this:

<!-- TestBench 4 --> 
<dependency org="com.vaadin" name="vaadin-testbench-api" rev="&vaadin.version;" conf="nodeploy -> default" />

Hope this helps,


Hi Guillermo,
after replacing “latest.release” with “&vaadin.version;” and cleaning Ivy cache, it did not work. I upgraded my Eclipse too and then it worked :slight_smile:


Glad to hear it worked!