Maven Vaadin broken?

I got a new desktop computer today at work. Did a completely clean, fresh, brand-new installation of Everything. New installation of Apache Tomcat 8. New Eclipse. New Vaadin (dragged the plug-in link from the download page to the Eclipse window). Tried creating a brand-new Vaadin 7 project, using a new selection from the menu I haven’t seen before: “Vaadin 7 Project (Maven)”. Ah, so they’re finally making Maven mandatory and eliminating Ivy. That’s fine, so long as they make it easy enough to learn to use.

New project created. Tomcat server up and running. Synchronized. Choose to do a “Debug on Server” and…


That’s not supposed to happen, is it?

So, clearly I must be doing something wrong, but since this is a completely new, fresh, clean installation of everything, what on Earth am I missing?

(By the way, I did try using Eclipse’s built-in right-click on the project → Run As → Maven Install. Seemed to be a successful run, but going to http://localhost:8080/ afterward still goes to the same error page above.

The workflow you describe to me sounds totally correct. I don’t think you are wrong and it should work, so this must be a bug in the plugin.

The Maven project creation is still very new and might still have some kinks to iron out. I would stick with the legacy project (ivy) for now and wait until a few maintenance releases comes out for the plugin ironing out most bugs with Maven.

Sorry about this. Looks like there was a problem with our builds which has been fixed now. There is a new version available on update site. Make sure you use at least the version 2.3.9 of the plugin and 1.0.5 of designer.

For those expecting the new Maven features: The new Maven version of the plugin is going to be released for testing on separate update site with different version number.

Okay, I removed 2.3.5, then used the update site to go to 2.3.9. Seems like a step backward, though, since there is only the one folder again for Vaadin, and it doesn’t include an entry to create a Maven version of a Vaadin project. The Legacy folder is gone.

Perhaps I should have kept 2.3.5 installed, with all its new Maven-y goodness, then did a straight update to 2.3.9 without uninstalling 2.3.5 first. Too late now, though, as it seems even trying to install 2.3.5 from the Eclipse Marketplace installs 2.3.9 instead; it must be cached on my HDD somewhere as the “latest version” and, thus, will refuse to install anything older than it. I don’t know. I’m just guessing.

Ok, if you want to take step forward with Maven projects, there is now 2.4 pre-release out to test upcoming Maven support. You just need to use our our experimental update site. Add new update site to your Eclipse:

  1. Go to: Help → Install new software…
  2. Press “Add…” and enter new updatesite information:
  3. Name:
    Vaadin Experimental
  4. URL

  5. Click Ok, check “Vaadin Plugin for Eclipse 2.4.0.alpha3” and click Finnish.

And if you have any feedback on this version, let us know here or in GitHub:


Hmmm, not so sure I want to use a pre-release version of Vaadin. I’m having enough trouble getting everything to work on the stable release of it. Besides, if it’s still in the alpha stages, then it’ll be some months–at least–before it becomes stable enough to take over. I’ll keep using the Ivy way of doing things for now.

Thanks for the help, though, @Sami!

Use the maven archetype for vaadin projects, create the pom manually, use the Spring Boot Initializr … the world is full of alternatives that doesn’t lock you into Eclipse.