Help with Vaadin Designer - MacBook Pro M1

Hi guys,

Can anyone help shed light on my problems with Vaadin Designer.

Firstly - it’s a new Macbook Pro with M1 max silicon.

IntelliJ IDEA 2022.1.2 (Community Edition)
Vaadin Designer 4.6.18
OpenJDK 64-Bit Server VM Temurin-17.0.4.1+1

I’ve downloaded ‘Start’ apps, and created a project from scratch.
Whenever I try to open the .ts file, I get “Please wait, loading view…”

I can switch to ‘source’ view, and see the code, but Edit mode and Preview Mode do nothing.

I’ve attached the log.

Thanks for any assistance.
idea.log (92.5 KB)

@graceful-hippo can you enable chrome editor ?
Go to Settings → Editor > Vaadin Designer and check “Enable Chrome editor”
unknown.png

this option active designer in chrome browser instead of Intellij editor.
I’ve had similar issue like yours with 4K monitors and I switched to browser. It works like a charm

Boom! Thanks. As you say, works like a charm. Thanks VERY much.

You’re welcome :slightly_smiling_face:

Not working for me, always stucked in “Please wait, loading view…”

Sorry this is for Vaadin 8 in Intellij, but I can’t find solution anywhere. In Eclipse it works ok

Could someone please help me? I’ve subscribed to a Pro License but Vaadin Designer (4.6.19) does not open in Intellij 2021.3.2. My vaadin project is in a Maven submodule. I’ve also created project-settings at the root of the module with { "--node.modules.project.name": "[module-name]" }. I’ve attached the Intellij log file. It seems that is still looking for node_modules in project root. Please let me know what todo

intellij.log (109 KB)

Also checked Enable Chrome editor doesn’t work either

Same problem

There was a fix that should have gone out like yesterday. See if you have an update for the plugin and try again.

Looks like it might be still held up in the JetBrains review queue

Should be out in a few days

Ok, thx a lot, will wait for it then! Finally!!!

Omg thanks!

Same issue. MacOs BigSur + IntelliJ IDEA 2022.2 (Ultimate Edition) + Designer 4.6.20. (( Enable Chrome editor helped.