GWT Widgetset compilation problem in 6.5.0

I upgraded to 6.5.0, after some startup problem now it works but when I try to recompile GWT Wigdetset I get a lot of errors (see below).
What’s wrong ?
What did I miss ?
Tks
Tullio

Compiling widgetset axioma.rubik.vaadin_rubik.widgetset.Vaadin_rubikWidgetset
Updating GWT module description file…
31-gen-2011 11.57.40 com.vaadin.terminal.gwt.widgetsetutils.ClassPathExplorer getAvailableWidgetSets
INFO: Widgetsets found from classpath:
com.vaadin.terminal.gwt.DefaultWidgetSet in jar:file:I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/
axioma.rubik.vaadin_rubik.widgetset.Vaadin_rubikWidgetset in file://I/Configuratore/VaadinRubik/vaadin-rubik/src/main/java
com.vaadin.addon.treetable.TreetableWidgetset in jar:file:I:/Configuratore/Maven/repository/org/vaadin/addons/vaadin-treetable/1.1.0/vaadin-treetable-1.1.0.jar!/

31-gen-2011 11.57.40 com.vaadin.terminal.gwt.widgetsetutils.ClassPathExplorer getAvailableWidgetSets
INFO: Search took 16ms
Done.
Starting GWT compiler
Compiling module axioma.rubik.vaadin_rubik.widgetset.Vaadin_rubikWidgetset
Validating newly compiled units
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VDragAndDropWrapper.java’
[ERROR]
Line 175: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/i18n/client/BidiPolicy.java’
[ERROR]
Line 29: The method hasAnyRTL() is undefined for the type LocaleInfo
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/core/client/testing/StubScheduler.java’
[ERROR]
Line 51: The method scheduleEntry(Scheduler.RepeatingCommand) of type StubScheduler must override or implement a supertype method
[ERROR]
Line 56: The method scheduleEntry(Scheduler.ScheduledCommand) of type StubScheduler must override or implement a supertype method
[ERROR]
Line 61: The method scheduleFinally(Scheduler.RepeatingCommand) of type StubScheduler must override or implement a supertype method
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/ValuePicker.java’
[ERROR]
Line 40: No source code is available for type com.google.gwt.editor.client.IsEditor; did you forget to inherit a required module?
[ERROR]
Line 40: No source code is available for type com.google.gwt.editor.client.LeafValueEditor; did you forget to inherit a required module?
[ERROR]
Line 42: No source code is available for type com.google.gwt.cell.client.AbstractCell; did you forget to inherit a required module?
[ERROR]
Line 43: No source code is available for type com.google.gwt.text.shared.Renderer; did you forget to inherit a required module?
[ERROR]
Line 50: No source code is available for type com.google.gwt.cell.client.Cell.Context; did you forget to inherit a required module?
[ERROR]
Line 50: No source code is available for type com.google.gwt.safehtml.shared.SafeHtmlBuilder; did you forget to inherit a required module?
[ERROR]
Line 57: No source code is available for type com.google.gwt.user.cellview.client.CellList; did you forget to inherit a required module?
[ERROR]
Line 58: No source code is available for type com.google.gwt.view.client.SingleSelectionModel; did you forget to inherit a required module?
[ERROR]
Line 65: No source code is available for type com.google.gwt.view.client.SelectionChangeEvent.Handler; did you forget to inherit a required module?
[ERROR]
Line 66: No source code is available for type com.google.gwt.view.client.SelectionChangeEvent; did you forget to inherit a required module?
[ERROR]
Line 85: No source code is available for type com.google.gwt.editor.client.adapters.TakesValueEditor; did you forget to inherit a required module?
[ERROR]
Line 85: The method of(TakesValue) in the type TakesValueEditor is not applicable for the arguments (ValuePicker)
[ERROR]
Line 94: The method asWidget() of type ValuePicker must override or implement a supertype method
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/Util.java’
[ERROR]
Line 611: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VCustomComponent.java’
[ERROR]
Line 69: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VUpload.java’
[ERROR]
Line 234: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/richtextarea/VRichTextArea.java’
[ERROR]
Line 301: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 343: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VNativeButton.java’
[ERROR]
Line 138: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VScrollTable.java’
[ERROR]
Line 833: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 1531: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 1566: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 1875: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 2795: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 4662: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 4779: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 4832: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 5445: The method getCharCode() is undefined for the type NativeEvent
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/HasDirectionalSafeHtml.java’
[ERROR]
Line 26: No source code is available for type com.google.gwt.safehtml.client.HasSafeHtml; did you forget to inherit a required module?
[ERROR]
Line 33: No source code is available for type com.google.gwt.safehtml.shared.SafeHtml; did you forget to inherit a required module?
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VWindow.java’
[ERROR]
Line 539: The method scheduleFinally(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 715: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 734: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/core/client/prefetch/Prefetcher.java’
[ERROR]
Line 55: The method setPrefetchQueue(int) is undefined for the type AsyncFragmentLoader
[ERROR]
Line 74: The method startPrefetching() is undefined for the type AsyncFragmentLoader
[ERROR]
Line 86: The method stopPrefetching() is undefined for the type AsyncFragmentLoader
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ApplicationConnection.java’
[ERROR]
Line 653: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VView.java’
[ERROR]
Line 243: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 375: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 436: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/LabelBase.java’
[ERROR]
Line 30: The type LabelBase must implement the inherited abstract method HasAutoHorizontalAlignment.setAutoHorizontalAlignment(AutoHorizontalAlignmentConstant)
[ERROR]
Line 31: No source code is available for type com.google.gwt.i18n.shared.HasDirectionEstimator; did you forget to inherit a required module?
[ERROR]
Line 43: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 43: No source code is available for type AutoHorizontalAlignmentConstant; did you forget to inherit a required module?
[ERROR]
Line 66: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 66: No source code is available for type AutoHorizontalAlignmentConstant; did you forget to inherit a required module?
[ERROR]
Line 67: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 70: No source code is available for type com.google.gwt.i18n.shared.DirectionEstimator; did you forget to inherit a required module?
[ERROR]
Line 83: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 84: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 126: The method setAutoHorizontalAlignment(AutoHorizontalAlignmentConstant) from the type LabelBase refers to the missing type AutoHorizontalAlignmentConstant
[ERROR]
Line 142: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 144: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 145: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 151: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 151: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 152: The method startOf(HasDirection.Direction) is undefined for the type HasHorizontalAlignment.HorizontalAlignmentConstant
[ERROR]
Line 153: The method endOf(HasDirection.Direction) is undefined for the type HasHorizontalAlignment.HorizontalAlignmentConstant
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VSlider.java’
[ERROR]
Line 182: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 232: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VMenuBar.java’
[ERROR]
Line 535: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (Command)
[ERROR]
Line 640: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/ShortcutActionHandler.java’
[ERROR]
Line 170: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 177: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 208: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/IntegerBox.java’
[ERROR]
Line 27: No source code is available for type com.google.gwt.text.client.IntegerRenderer; did you forget to inherit a required module?
[ERROR]
Line 28: No source code is available for type com.google.gwt.text.client.IntegerParser; did you forget to inherit a required module?
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/ValueBox.java’
[ERROR]
Line 42: No source code is available for type com.google.gwt.text.shared.Renderer; did you forget to inherit a required module?
[ERROR]
Line 42: No source code is available for type com.google.gwt.text.shared.Parser; did you forget to inherit a required module?
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/core/client/impl/CrossSiteIframeLoadingStrategy.java’
[ERROR]
Line 21: The import com.google.gwt.core.client.impl.AsyncFragmentLoader.LoadTerminatedHandler cannot be resolved
[ERROR]
Line 36: The type CrossSiteIframeLoadingStrategy must implement the inherited abstract method AsyncFragmentLoader.LoadingStrategy.startLoadingFragment(int, AsyncFragmentLoader.LoadErrorHandler)
[ERROR]
Line 99: LoadTerminatedHandler cannot be resolved to a type
[ERROR]
Line 136: LoadTerminatedHandler cannot be resolved to a type
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/MenuBar.java’
[ERROR]
Line 383: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (Command)
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VFilterSelect.java’
[ERROR]
Line 1098: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/NumberLabel.java’
[ERROR]
Line 72: No source code is available for type com.google.gwt.text.client.NumberFormatRenderer; did you forget to inherit a required module?
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VTree.java’
[ERROR]
Line 1517: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 1577: The method getCharCode() is undefined for the type NativeEvent
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VOptionGroup.java’
[ERROR]
Line 194: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/DateLabel.java’
[ERROR]
Line 50: No source code is available for type com.google.gwt.text.client.DateTimeFormatRenderer; did you forget to inherit a required module?
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/i18n/client/AutoDirectionHandler.java’
[ERROR]
Line 35: No source code is available for type com.google.gwt.i18n.shared.HasDirectionEstimator; did you forget to inherit a required module?
[ERROR]
Line 74: No source code is available for type com.google.gwt.i18n.shared.WordCountDirectionEstimator; did you forget to inherit a required module?
[ERROR]
Line 103: No source code is available for type com.google.gwt.i18n.shared.DirectionEstimator; did you forget to inherit a required module?
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VTextArea.java’
[ERROR]
Line 73: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/DoubleBox.java’
[ERROR]
Line 28: No source code is available for type com.google.gwt.text.client.DoubleRenderer; did you forget to inherit a required module?
[ERROR]
Line 29: No source code is available for type com.google.gwt.text.client.DoubleParser; did you forget to inherit a required module?
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VSplitPanel.java’
[ERROR]
Line 266: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/ValueBoxBase.java’
[ERROR]
Line 49: No source code is available for type com.google.gwt.i18n.shared.HasDirectionEstimator; did you forget to inherit a required module?
[ERROR]
Line 50: No source code is available for type com.google.gwt.editor.client.IsEditor; did you forget to inherit a required module?
[ERROR]
Line 50: No source code is available for type com.google.gwt.editor.ui.client.adapters.ValueBoxEditor; did you forget to inherit a required module?
[ERROR]
Line 83: No source code is available for type com.google.gwt.text.shared.Parser; did you forget to inherit a required module?
[ERROR]
Line 84: No source code is available for type com.google.gwt.text.shared.Renderer; did you forget to inherit a required module?
[ERROR]
Line 162: No source code is available for type com.google.gwt.i18n.shared.DirectionEstimator; did you forget to inherit a required module?
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/core/client/impl/CrossSiteLoadingStrategy.java’
[ERROR]
Line 21: The import com.google.gwt.core.client.impl.AsyncFragmentLoader.LoadTerminatedHandler cannot be resolved
[ERROR]
Line 34: The type CrossSiteLoadingStrategy must implement the inherited abstract method AsyncFragmentLoader.LoadingStrategy.startLoadingFragment(int, AsyncFragmentLoader.LoadErrorHandler)
[ERROR]
Line 97: LoadTerminatedHandler cannot be resolved to a type
[ERROR]
Line 153: LoadTerminatedHandler cannot be resolved to a type
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VTabsheet.java’
[ERROR]
Line 353: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 913: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/LongBox.java’
[ERROR]
Line 28: No source code is available for type com.google.gwt.text.client.LongRenderer; did you forget to inherit a required module?
[ERROR]
Line 29: No source code is available for type com.google.gwt.text.client.LongParser; did you forget to inherit a required module?
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/ValueLabel.java’
[ERROR]
Line 36: No source code is available for type com.google.gwt.editor.client.IsEditor; did you forget to inherit a required module?
[ERROR]
Line 36: No source code is available for type com.google.gwt.editor.client.LeafValueEditor; did you forget to inherit a required module?
[ERROR]
Line 82: No source code is available for type com.google.gwt.text.shared.Parser; did you forget to inherit a required module?
[ERROR]
Line 95: No source code is available for type com.google.gwt.text.shared.Renderer; did you forget to inherit a required module?
[ERROR]
Line 125: No source code is available for type com.google.gwt.editor.client.adapters.TakesValueEditor; did you forget to inherit a required module?
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/DirectionalTextHelper.java’
[ERROR]
Line 32: No source code is available for type com.google.gwt.i18n.shared.HasDirectionEstimator; did you forget to inherit a required module?
[ERROR]
Line 37: No source code is available for type com.google.gwt.i18n.shared.DirectionEstimator; did you forget to inherit a required module?
[ERROR]
Line 38: No source code is available for type com.google.gwt.i18n.shared.WordCountDirectionEstimator; did you forget to inherit a required module?
[ERROR]
Line 228: No source code is available for type com.google.gwt.i18n.shared.BidiFormatter; did you forget to inherit a required module?
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/ValueListBox.java’
[ERROR]
Line 45: No source code is available for type com.google.gwt.editor.client.IsEditor; did you forget to inherit a required module?
[ERROR]
Line 45: No source code is available for type com.google.gwt.editor.client.adapters.TakesValueEditor; did you forget to inherit a required module?
[ERROR]
Line 49: No source code is available for type com.google.gwt.text.shared.Renderer; did you forget to inherit a required module?
[ERROR]
Line 50: No source code is available for type com.google.gwt.view.client.ProvidesKey; did you forget to inherit a required module?
[ERROR]
Line 56: No source code is available for type com.google.gwt.view.client.SimpleKeyProvider; did you forget to inherit a required module?
[ERROR]
Line 86: The method of(TakesValue) in the type TakesValueEditor is not applicable for the arguments (ValueListBox)
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/core/client/prefetch/RunAsyncCode.java’
[ERROR]
Line 63: The method isAlreadyLoaded(int) is undefined for the type AsyncFragmentLoader
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/user/client/ui/HasAutoHorizontalAlignment.java’
[ERROR]
Line 30: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 30: No source code is available for type AutoHorizontalAlignmentConstant; did you forget to inherit a required module?
[ERROR]
Line 31: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 38: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 38: No source code is available for type AutoHorizontalAlignmentConstant; did you forget to inherit a required module?
[ERROR]
Line 39: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 54: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Line 54: No source code is available for type AutoHorizontalAlignmentConstant; did you forget to inherit a required module?
[ERROR]
Line 77: AutoHorizontalAlignmentConstant cannot be resolved to a type
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/core/client/impl/XhrLoadingStrategy.java’
[ERROR]
Line 18: The type com.google.gwt.core.client.impl.AsyncFragmentLoader.HttpDownloadFailure is not visible
[ERROR]
Line 19: The import com.google.gwt.core.client.impl.AsyncFragmentLoader.HttpInstallFailure cannot be resolved
[ERROR]
Line 20: The import com.google.gwt.core.client.impl.AsyncFragmentLoader.LoadTerminatedHandler cannot be resolved
[ERROR]
Line 50: The type XhrLoadingStrategy must implement the inherited abstract method AsyncFragmentLoader.LoadingStrategy.startLoadingFragment(int, AsyncFragmentLoader.LoadErrorHandler)
[ERROR]
Line 129: LoadTerminatedHandler cannot be resolved to a type
[ERROR]
Line 131: LoadTerminatedHandler cannot be resolved to a type
[ERROR]
Line 133: LoadTerminatedHandler cannot be resolved to a type
[ERROR]
Line 164: LoadTerminatedHandler cannot be resolved to a type
[ERROR]
Line 198: LoadTerminatedHandler cannot be resolved to a type
[ERROR]
Line 219: LoadTerminatedHandler cannot be resolved to a type
[ERROR]
Line 249: HttpInstallFailure cannot be resolved to a type
[ERROR]
Line 253: HttpDownloadFailure cannot be resolved to a type
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/i18n/client/impl/CurrencyDataJso.java’
[ERROR]
Line 37: Only one JavaScriptObject type may implement the methods of an interface that declared methods. The interface (com.google.gwt.i18n.client.CurrencyData) is implemented by both (com.google.gwt.i18n.client.impl.CurrencyDataImpl) and (com.google.gwt.i18n.client.impl.CurrencyDataJso)
[ERROR]
Line 51: The method getDefaultFractionDigits() in the type CurrencyDataImpl is not applicable for the arguments (int)
[ERROR]
Line 59: The method isDeprecated() in the type CurrencyDataImpl is not applicable for the arguments (int)
[ERROR]
Line 63: The method isSpaceForced() in the type CurrencyDataImpl is not applicable for the arguments (int)
[ERROR]
Line 67: The method isSpacingFixed() in the type CurrencyDataImpl is not applicable for the arguments (int)
[ERROR]
Line 71: The method isSymbolPositionFixed() in the type CurrencyDataImpl is not applicable for the arguments (int)
[ERROR]
Line 75: The method isSymbolPrefix() in the type CurrencyDataImpl is not applicable for the arguments (int)
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VContextMenu.java’
[ERROR]
Line 140: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar!/com/vaadin/terminal/gwt/client/ui/VTextField.java’
[ERROR]
Line 261: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Line 300: The method scheduleDeferred(Scheduler.ScheduledCommand) in the type Scheduler is not applicable for the arguments (new Command(){})
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/emul/java/util/logging/Logger.java’
[ERROR]
Line 28: No source code is available for type com.google.gwt.logging.impl.LoggerImpl; did you forget to inherit a required module?
[ERROR]
Line 28: No source code is available for type com.google.gwt.logging.impl.LoggerImplNull; did you forget to inherit a required module?
[ERROR]
Errors in ‘jar:file:/I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar!/com/google/gwt/emul/java/util/logging/Level.java’
[ERROR]
Line 31: No source code is available for type com.google.gwt.logging.impl.LevelImpl; did you forget to inherit a required module?
[ERROR]
Line 31: No source code is available for type com.google.gwt.logging.impl.LevelImplNull; did you forget to inherit a required module?
Finding entry point classes
[ERROR]
Unable to find type ‘com.vaadin.terminal.gwt.client.ApplicationConfiguration’
[ERROR]
Hint: Previous compiler errors may have made this type unavailable
[ERROR]
Hint: Check the inheritance chain from your module; it may not be inheriting a required module or a module may not be adding its source path entries properly
Widgetset compilation failed

Nobody can help ?
Tks
Tullio

Hi,

Vaadin 6.5.0 requires GWT 2.1.0. From the error message you posted, I would guess that you are using an older version of GWT in the compilation.

  • Teemu

I’m sure You are right but, where can I look into in order to find the problem ?
This is my pom.xml
Tks
Tullio

<?xml version="1.0" encoding="UTF-8"?>


4.0.0
Rubik
vaadin-rubik
war
0.0.2-SNAPSHOT
Vaadin Web Application

UTF-8 org.apache.maven.plugins maven-compiler-plugin 1.5 1.5
  <!-- Compile custom GWT components or widget dependencies with the GWT compiler -->
  <!--
  <plugin>
    <groupId>org.codehaus.mojo</groupId>
    <artifactId>gwt-maven-plugin</artifactId>
    <version>2.1.0-1</version>
    <configuration>
      <webappDirectory>${project.build.directory}/${project.build.finalName}/VAADIN/widgetsets</webappDirectory>
      <extraJvmArgs>-Xmx512M -Xss1024k</extraJvmArgs>
      <runTarget>vaadin-rubik</runTarget>
      <hostedWebapp>${project.build.directory}/${project.build.finalName}</hostedWebapp>
      <noServer>true</noServer>
      <port>8080</port>
      <soyc>false</soyc>
    </configuration>
    <executions>
      <execution>
        <goals>
          <goal>resources</goal>
          <goal>compile</goal>
        </goals>
      </execution>
    </executions>
  </plugin>
  <plugin>
    <groupId>com.vaadin</groupId>
    <artifactId>vaadin-maven-plugin</artifactId>
    <version>1.0.1</version>
    <executions>
      <execution>
        <configuration>
        </configuration>
        <goals>
          <goal>update-widgetset</goal>
        </goals>
      </execution>
    </executions>
  </plugin>
  -->

  <!-- A simple Jetty test server at http://localhost:8080/vaadin-rubik can be launched with the Maven goal jetty:run 
    and stopped with jetty:stop -->
  <plugin>
    <groupId>org.mortbay.jetty</groupId>
    <artifactId>maven-jetty-plugin</artifactId>
    <version>6.1.24</version>
    <configuration>
      <stopPort>9966</stopPort>
      <stopKey>vaadin-rubik</stopKey>
      <!-- Redeploy every x seconds if changes are detected, 0 for no automatic redeployment -->
      <scanIntervalSeconds>0</scanIntervalSeconds>
      <!-- make sure Jetty also finds the widgetset -->
      <webAppConfig>
        <contextPath>/vaadin-rubik</contextPath>
        <baseResource implementation="org.mortbay.resource.ResourceCollection">
          <!-- Workaround for Maven/Jetty issue http://jira.codehaus.org/browse/JETTY-680 -->
          <!-- <resources>src/main/webapp,${project.build.directory}/${project.build.finalName}</resources> -->
          <resourcesAsCSV>src/main/webapp,${project.build.directory}/${project.build.finalName}</resourcesAsCSV>
        </baseResource>
      </webAppConfig>
    </configuration>
  </plugin>
</plugins>
vaadin-snapshots http://oss.sonatype.org/content/repositories/vaadin-snapshots/ false true vaadin-addons http://maven.vaadin.com/vaadin-addons JBOSS http://repository.jboss.org/maven2 axioma-pax-repo-releases Axioma Pax Repository Releases http://aximisvn:8081/artifactory/axioma-pax-framework-releases true false com.vaadin vaadin 6.5.0 org.vaadin.addons navigator7 7.49 org.vaadin.addons blackboard 2.1.1 com.google.gwt gwt-user 2.1.1 javax.servlet servlet-api 2.5 Rubik base-rubik 0.0.2-SNAPSHOT org.vaadin.addons vaadin-treetable 1.1.0

You are surely right, the error is in the first line below, when I try to compile from eclipse

Executing compiler with parameters [C:\Programmi\Java\jdk1.6.0_21\bin\java.exe, -Djava.awt.headless=true, -Xss8M, -Xmx512M, -XX:MaxPermSize=512M, -classpath, C:\Programmi\Java\jdk1.6.0_21\jre\lib\rt.jar;I:/Configuratore/VaadinRubik/vaadin-rubik/src/main/java;I:/Configuratore/VaadinRubik/vaadin-rubik/src/main/resources;I:/Configuratore/VaadinRubik/vaadin-rubik/target/classes;I:/Configuratore/Sts/sts-2.5.1.RELEASE/configuration/com.vaadin.integration.eclipse/download/gwt-dev/2.0.4/gwt-dev.jar;I:/Configuratore/Sts/sts-2.5.1.RELEASE/configuration/com.vaadin.integration.eclipse/download/gwt-user/2.0.4/gwt-user.jar;I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.0/vaadin-6.5.0.jar;I:/Configuratore/Sts/sts-2.5.1.RELEASE/configuration/com.vaadin.integration.eclipse/download/gwt-dev/2.0.4/gwt-dev.jar;I:/Configuratore/Maven/repository/org/vaadin/addons/vaadin-treetable/1.1.0/vaadin-treetable-1.1.0.jar;I:/Configuratore/Sts/sts-2.5.1.RELEASE/configuration/com.vaadin.integration.eclipse/download/
gwt-user/2.0.4/gwt-user.ja
r;I:/Configuratore/Maven/repository/com/google/gwt/gwt-user/2.1.1/gwt-user-2.1.1.jar, com.vaadin.tools.WidgetsetCompiler, -out, src/main/webapp/VAADIN/widgetsets, -localWorkers, 2, -logLevel, INFO, axioma.rubik.vaadin_rubik.widgetset.Vaadin_rubikWidgetset]
Updating GWT module description file…

It uses 2.0.4 and not 2.1.0-1.
However I don’t know what I should modify in order to change it.
In the pom they seems to be correct.
My Vaadin integration plugin sems up to date (1.3.1).
Should I download something missing ?
Tks
Tullio

I am not sure how you created the Eclipse project as you seem to be using Maven, so:

If you are using m2eclipse, select “Maven → Update dependencies” (if I remember correctly) from the project context menu - assuming your POM refers to the correct versions of GWT.

If you created it with the Maven goal eclipse:eclipse to build the .project and .classpath from scratch based on your POM, you can rerun it - but note that it completely overwrites those files so you might want to make backups of them and the project settings first.

An older version of the Eclipse integration plugin had a race condition that caused the GWT class path references not to be automatically updated correctly in some cases - systematically on some computers.

Yes, I created it with maven.
Yes, I’m using m2eclipse and executed update maven dependncies but nothing changed.
I didn’t use mvn from command line to create the project but I used a maven archetype from eclipse.
The version of the plugin I use is 1.3.1.201012171040.
I tried to delete and install it again but it sill downloaded only 2.0.4 (as far from I:\Configuratore\Sts\sts-2.5.1.RELEASE\configuration\com.vaadin.integration.eclipse\download\gwt-user directory).
Tks
Tullio

I had the same problem in Eclipse with a regular non-Maven project. I first had to update the Vaadin plugin (I’m using the experimental version but the regular should work). The plugin has some sort of problem that it doesn’t always download the proper GWT version, but after I reverted to an older (6.4.8) and then back to 6.5.0 (or actually the latest nightly), it downloaded the proper GWT just fine.

I deleted the plugin and reinstalled it, however it still downloads vaadin 6.4.8 jar and gwt 2.0.4.
In the pom of my maven project I’ve vaadin 6.5.0 but it doesn’t seem to be interested in suc definiton.
I changed my pom from 6.5.0 to 6.4.8 and back again but nothing changed.
How can I force th plugin to download the correc version ?
Tks
Tullio

I now noticed that the gwt-maven-plugin and the vaadin-maven-plugin definitions are commented out in the POM you posted earlier, so that would be the first thing to check.

Then try compiling the widgetset from the command line with “mvn gwt:clean vaadin:update-widgetset gwt:compile” and check the versions used. If that uses the correct versions, you have a problem with Eclipse.

If the command line compilation uses the wrong versions, check your POM against a new project created with the latest version of vaadin-archetype-sample .

Once you get it working, you could also move the two build plugin definitions under a dependencyManagement section in your POM to make widgetset compilation only occur upon explicit command.

Uncommenting dependencies doesn’t solve.
Command line execution downloaded the required material bug gave me some errors.
How can I verify if everything goes ok ?
In the VAADIN/widgetset directory nothing changed.
Tks
Tullio

I upgraded to 6.5.1.
During upgrade I get
11/02/11 17.11.51 CET: [ERROR]
11-feb-2011 17.11.51 com.vaadin.terminal.gwt.widgetsetutils.ClassPathExplorer getAvailableWidgetSets
11/02/11 17.11.51 CET: [ERROR]
INFO: Widgetsets found from classpath:
11/02/11 17.11.51 CET: [ERROR]
com.vaadin.terminal.gwt.DefaultWidgetSet in jar:file:I:/Configuratore/Maven/repository/com/vaadin/vaadin/6.5.1/vaadin-6.5.1.jar!/
11/02/11 17.11.51 CET: [ERROR]
axioma.rubik.vaadin_rubik.widgetset.Vaadin_rubikWidgetset in file://I/Configuratore/VaadinRubik/vaadin-rubik/src/main/java
11/02/11 17.11.51 CET: [ERROR]
com.vaadin.addon.treetable.TreetableWidgetset in jar:file:I:/Configuratore/Maven/repository/org/vaadin/addons/vaadin-treetable/1.1.0/vaadin-treetable-1.1.0.jar!/
11/02/11 17.11.51 CET: [ERROR]

11/02/11 17.11.51 CET: [ERROR]
11-feb-2011 17.11.51 com.vaadin.terminal.gwt.widgetsetutils.ClassPathExplorer getAvailableWidgetSets
11/02/11 17.11.51 CET: [ERROR]
INFO: Search took 16ms

Again widgetset problems ???
Tks
Tullio

Maven shows this output from the widgetset scan (which is performed by a class in the Vaadin distribution) as errors - in reality they are just informative messages. If there are no other problems, these do not represent real errors.

To be modified at some point so that the output would not be displayed as errors, I believe there is a ticket about this.

I’ve again problems with widgetset compilation in 6.5.7
I downloaded with Maven 6.5.7 and tried to execute but it failed with
INFO: Requested resource [VAADIN/widgetsets/com.vaadin.terminal.gwt.DefaultWidgetSet/D8DE943ACCA890E572902FBD2426AA79.cache.html]
not found from filesystem or through class loader. Add widgetset and/or theme JAR to your classpath or add files to WebContent/VAADIN folder.

Then I tried,as usual, to compile widgetset ignoring errors (as usual) but it didn’t work.
I was forced to go back to 6.5.6.
What can I do ?
Tks
Tullio

No help ?
Tks
Tullio