Grid doesn't want to fullfill my requests on nullRepresentation?!?

Hello all…
Working on Vaadin 7. I write after reading all forums and trying all combinations in my source code, but really cannot get it to work properly. Sure it’s a newbie fault but i really have no clue.
I extended the Grid class adding retro compatibility methods that will transform my legacy grid class calls to vaadin grid calls, so my app developers can port their code more efficiently.
I’m stuck with that null representation for numbes and strings.
I tried to set the nullRepresentation when adding a new column (result is the newly created Column object):

    if( String.class.isAssignableFrom( colType )) {
      result.setRenderer( new TextRenderer());
      ((TextField)result.getEditorField()).setNullRepresentation( "" );

also tried this one:

  if( String.class.isAssignableFrom( colType )) {
      TextField editor = new TextField();
      editor.setNullRepresentation( "" );
      result.setEditorField( editor );

and also tried adding a custom field factory:

    FieldGroup fieldGroup = grid.getEditorFieldGroup();
    fieldGroup.setFieldFactory(new EditorFieldFactory());
    grid.setEditorFieldFactory(new EditorFieldFactory());


  public class   EditorFieldFactory
         extends DefaultFieldGroupFieldFactory
    public <T extends Field> T createField( Class<?> dataType, Class<T> fieldType ) {
      T result = super.createField( dataType, fieldType );
      if( result instanceof TextField ) {
        ((TextField)result).setNullRepresentation( "" );
      return result;

I can see that the setNullRepresentation is invoked when creating a column on a string type, but the editor still shows “null” instead of “” when editing.
If i comment out the column creation part, i’d expect the FieldFactory to be called but no way. It’s never called.
Where am i wrong?

Thank you!