Grid component not available

I am using Eclipse Luna (4.4.1). I installed the latest Vaadin plugin (2.3.9) from the Eclipse marketplace. I am not able to use the Grid component. Is there something else i need to do?

John.

Hi John,

Can you be a bit more specific? What kind of project (maven / ivy) do you have? Do other components work for you, but not grid, or is it all components? Are you getting an error message?

Best regards,
Olli Tietäväinen

Hi Olli,

Everything else works fine (Tables, Buttons etc.). I cannot use the Grid item.

Maven is integrated with Eclipse. I did see my pom.xml references Vaadin 7.3.3. Chaning this resulted in other errors. I assumed i should use the Eclipse plugin.

John.

25601.png
25602.png

Hi John,


Grid was introduced in Vaadin 7.4
, so 7.3.3 won’t have it available. I’m not sure where your project setup is going wrong, but there’s always the option of creating the project using the maven archetype from command line (see https://vaadin.com/maven ). You can then import it to your Eclipse workspace using Import → Existing Maven Projects.

-Olli

Hi,

As mentioned earlier, i am usiing the Vaadin plugin for Eclipse.

In my project POM.XML, i changed the following:-

true 7.5.6 ${vaadin.version} UTF-8 UTF-8

When i run my project, i now receive:-

Failed to load the bootstrap javascript:-
./VAADIN/vaadinBootstrap.js?v=7.5.6

Any ideas?

Hi,

have you run Maven clean and install on your project? You can find these from the “Run As…” menu, or you can do “Maven build…” with
clean install
as the goals.

-Olli

Hi,

yes, tested this without success. Could it be the fact that jre7 is used and tools.jar is not found during compilation?

John

You should use a JDK instead of a JRE. Java 7 should be fine, although Java 8 is preferrable.

I have tried this with Java 8 JDK. It compiles OK (clean install), but when i run, get the bootstrap error:-

Failed to load the bootstrap javascript: ./VAADIN/vaadinBootstrap.js?v=7.6.5

My POM.XML is as follows:-

false [b] 7.6.5 [/b] ${vaadin.version} UTF-8 UTF-8

If i change my POM.XML back to:-

false [b] 7.3.3 [/b] ${vaadin.version} UTF-8 UTF-8

and rebuild (clean install) It works…

Hi,

the “failed to load the boostrap javascript” error sounds like you don’t have the correct vaadin-server.jar in your package or on the server. This could happen because of several reasons;
this thread
has more discussion about it. Maybe you’ll find some more information there.

Hope this helps,
Olli

If i change my POM to either 7.3.3 or .7.4.2 it works… as soon as i try 7.6.5, say, i get the error. This suggests its something in a later version? The jar appears to be wrapped in the WAR file correctly (as the change to 7.4.2 proved).

false [b] 7.3.3 [/b] ${vaadin.version} UTF-8 UTF-8

or

false [b] 7.4.2 [/b] ${vaadin.version} UTF-8 UTF-8