FilteringTable with Maven misses PopupButton


I built my Vaadin 7.0.0 project with:

Then, in my Maven POM.xml, I added FilteringTable add-on like this:

Then I removed my widgetsets directory (to force new GWT compilation) and did a

And got this error message:

Could not find a workaround on the web that worked for me.
Any hints?


looks like I have forgot to put a pom.xml file into add-on, or rather I was unaware that I should add one. I’ll see to it that the next version will have this, then the dependency management should function properly.

In the meantime I think you just need to add the PopupButton dependency to your own pom.xml by hand.


I already tried this, but I can’t find that add-on …

Oh ok, here’s a
to the Directory page.

Replying to myself - there’s now a new version (0.8.1.v7) in the Directory. This includes the pom.xml which should fix the dependency issue. Please try it out and let us know if it worked :slight_smile:

Thanks, very nice, works as expected!

Found out why I did not find PopupButton add-on: I used the top-right search field, not the one on left-side (which I simply haven’t seen until now) :bashful:.