File Upload component not working on Glassfish 4.1

Hello,

I have an File Upload component into my application( Vaadin 7.3.4) and it used to work as it should on Glassfish 3.1.2.2.
I use it to upload images of type .jpeg, .png, or .bmp.

After moving my appliction to Glassfish 4.1, th upload component is not working anymore. I does not upload any image or even file. There is no error showing on the log file. It just does not upload anything. Actually I use the immidate mode of uploading the images.

I’ve also tried changing to Vaadin 7.3.10 but nothing changes. It works fine on Glassfish 3.1.2.2 but it does not work on Glassfish 4.1.

I’ve also tried a different build of Glassfish 4.1 actually build glassfish-4.1-b13-11_02_2014, but the problem is still the same.

As this is an important component in my application’s functionallities I’m stuck on Glassfish 3.1.2.2

Any suggestion would really be appriciated.

Klaudeta

Hi,

That sounds rather critical, but with a quick try I couldn’t repeat the issue and upload worked fine for me. Do you have a simple example code you could share, that would really help to resolve the issue.

There seems to be an old glassfish-upload issue here:
http://dev.vaadin.com/ticket/12508

cheers,
matti

Hi,

I’ve attached a UI class using the File Upload component. I have used Vaadin 7.3.10 and Glassfish 4.1 build 13.

The problem is the same, the files of type (.jpeg, .png, .doc) don’t get uploaded. And it seems that nothing get executed inside the event listeners of the upload component.

I’ve also opened the Google Chrome Developer Tools, opened the Sources section and I can see that on the application folder TestUpload (it’s the name of the application I’ve deployed on Glassfish wher the UI class is in) there is a folder that gets created when I click the Start Upload button APP/UPLOAD/0/2/action and inside this folder there is an XML file that I’ve also attched here. What is strange is that into this XML file there is this message:
…The server encountered an internal error that prevented it from fulfilling this request.


GlassFish Server Open Source Edition 4.1 …

Klaudeta
18009.java (4.27 KB)

I’m not able to attach the XML file so I’m posting it here:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>
GlassFish v4 - Error report
</title>
<style type="text/css">
<!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;}  B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P{font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}HR {color : #525D76;}--></style>
</head>
<body>
<h1>HTTP Status 500 - </h1>
<hr/>
<p><b>type</b>
Status report</p>
<p><b>message</b></p>
<p><b>description</b>
The server encountered an internal error that prevented it from fulfilling this request.
</p><hr/>
<h3>GlassFish Server Open Source Edition  4.1 </h3>
</body>
</html>

I have opend a ticket for this problem
http://dev.vaadin.com/ticket/17108

As I’m not able to post my comment there because of this message: Submission rejected as potential spam. SpamBayes determined spam probability of 100.00%

I am doing it here.

I had two versions of GF 4.1 (one was a night build) on which I have been working for some months now on my two projects both with VAADIN. I recall to only creating JDBC and JMS resources on both of them and I’m using JREBEL agent for development. I never was able to get the Upload working. Even the test project having the UI that I have attached above do not work on these two GF 4.1.

After reading your comments here of not being able to reproduce the problem, I download GF 4.1 from the website and guess what? Upload works. It still doesn’t work on my previous GF 4.1 copies. I tried also to use the same zip files that I used to install my old copies of GF, extracting them in different location and yes, Upload is working.

I’m trying to remember/understand what I’ve changed on my old copies of GF that causes Upload to not work but I can not remember anything and I feel kind of embarrassment for wasting your time.

I have moved my projected to a fresh GF 4.1 installation and everything seems good.

Thank you very much and sorry for the unnecessary ticket.