Failing to load the website?

Hello, I am beginner in Vaadin, I’ve started with instructions (https://vaadin.com/docs/latest/guide/quick-start) and when I am trying to run the application, it says this to me. How can I fix it? Thanks.

TypeError: Failed to fetch dynamically imported module: http://localhost:8080/VAADIN/@fs/C:/Users/adoni/IdeaProjects/my-todo/target/frontend/generated-flow-imports.js

image.png

I can’t tell what your problem is. But the best way to start is https://start.vaadin.com

Thank you, let me try that.

It seems that problem is the same.
image.png

(And I found out, that mvnw command in terminal doesn’t work for me)

image.png

you are in Powershell

you have to use .\mvnw

I’ve tried both ways and it also the tutorial todo app works

I have to use Java 17 in JAVA_HOME for it to work properly, right?

Okay, I set the JAVA_HOME to Java 17 and same result.

I also tried to going into that path and removing it, so it can be reseted, but that didn’t helped.

(and yea, maven - I downloaded sources and documentation, generated sources and updated folders and reloaded it)

Pretty weird issue.

Are you using IntelliJ?

have you tried to start the application from there?

Yes, I am using IntelliJ, I tried both ways. (.\mvnw and run application in there)

That’s strange

open a cmd windows instead of powershell

then try