Failed to load the widgetset: ./VAADIN/widgetsets/com.vaadin.DefaultWidgetS


First I have to say “sorry, my english is bad”. And second "Why you dont have “Discussion in Finnish”? You have team in Finland and maybe they can help with finnish?

I have read so many posts about this problem but I didnt resolve it, yet. I create my first Vaadin project and it works great in my local (dev)computer. But now I deploy it and I move it to the server. (Actually my server is Raspberry Pi with Tomcat(7?)) So, my project works great with Chromium or Firefox when I drive it in my local pc where I dev it. But in my Raspberry it doesn’t work with Firefox, but it work with Chromium.

I get allways errortext “Failed to load the widgetset: ./VAADIN/widgetsets/com.vaadin.DefaultWidgetSet/com.vaadin.DefaultWidgetSet.nocache.js?1403552915104” with Firefox and then it takes about 20 second and I get my form to the screen.

So I have read so many threads about this errortext but I dont resolve it? Can you please help me? I am new and I dont know so much. I dont even have web.xml file and if I have, i dont know what to do with it.

I love Vaadin, I wants to use it in my next project but I have problem and I cant resolve it. Please step by step instructions. :wink:

What Vaadin version are you using?
Might be something similar then what happened here:

I am using Vaadin 7.2.2 in my project and my Firefox is 30.0.

Today I get my productionServer (vps) and tommorrow I gonna install tomcat etc. to it… Then I deploy and test. Lets see…

Catalina.out doesn’t give any exception or error…

No, it’s not work…

Any help?

Regarding a Finnish section in forum, I guess the volume of discussion would be very very low, as for example the French community only has 8 posts in over a year and there are a lot more people globally speaking French than Finnish. Besides, your English is good and Marius here wouldn’t have noticed it if it would have been in Finnish. I’m one of the guys in the Finnish office btw.

So onto the topic. Vaadin uses GWT. GWT compiles Java into Javascript. The compiled codebase is called a widgetset. As the error message is trying to look for DefaultWidgetSet, it means that you have no custom client side code and aren’t using add-ons. This simplifies the problem a bit.

The DefaultWidgetSet is provided in one of the jars, vaadin-client-compiled-7.X.X.jar. It seems that you don’t either have this or it can’t access it for some reason. It is hard to help out as I don’t know exactly what your project looks like. Have you created the project with Maven, the Vaadin Eclipse plugin, by doing a custom web project and copying in all the jars or something completely different? How do you build your project into a war file which you deploy to your Pi? Does the tomcat logs tell you anything extra? The war file is just a zip file so you can look into it as well. It problem might be somewhere else than in the war file but that is my best guess.

I have a feeling that when you say “works great in my local (dev)computer”, you run it within your IDE, like Eclipse or whatever. You should try to deploy it into a clean tomcat locally first. Download a new copy of tomcat, put the war into the webapps folder, run the startup script, check browser, check log.

That’s about what pops into my mind with the current info.

!Now it works!

I don’t know what I do :smiley:

I think that my biggest problem was tomcat… :confused: I just re-install my (production)server tomcat and now it works great. When I have this problem, deploy takes about 3-4 minutes in server… Now it takes about 1 minute… I really dont know what was the problem…

Hope so, I get my RPi works too, because I don’t like this sound what I have to hear from my server.

Thank, I will be back when I get my next problem. Have a nicce summer!

Hah, great that it works now. Hopefully the problems won’t come back. :wink: Nice summer to you aswell.

Hi everyone,
I am new to vaadin and I am facing issue which says “failed to load vaadin widgetSet Widgetset.nocache.js?1525352692498”.Could anyone help me in this.
I am using eclipse for this.