executeJavascript giving permission denied in IE and hanging application


I am executing a javascript statement in my vaadin code


I’m actually using a valid domain I can switch to

It works in FF and Chrome fine, but in IE I get an error in the console

Thu Jul 31 15:38:40 GMT+800 2014 com.vaadin.client.VConsole
INFO: Server to client RPC call: 2:com.vaadin.shared.extension.javascriptmanager.ExecuteJavaScriptRpc.executeJavaScript([document.domain='mydomain.com']
Thu Jul 31 15:20:37 GMT+800 2014 com.vaadin.client.ApplicationConfiguration
SEVERE: (Error) : Permission deniedcom.google.gwt.core.client.JavaScriptException: (Error) : Permission denied

Then I just get the vaadin loading indicator whizzing round and round in the top right corner and nothing happens.

Despite the error, the change to document domain was actually successful and worked correctly.

I’ve tried wrapping it in a try catch with no avail

I ended up putting it in a setTimeout() and it worked and didn’t cause issues, but ended up being rather ugly (The whole point was because this was in an iFrame and needed to acccess the parent frame).

I have subsequent javascript with a window.location and I append the top level browser query string to the iFrame, which should cause the vaadin navigator to trigger, but this doesn’t work in IE either (and still causes an error even if in a set timeout). So I solved this by a location.reload() after change the location.

Just seems that executeJavascript and IE have some issues?