Error when deploying Vaadin portlet to Liferay 5.0.1

we faced a problem, we have created Vaadin (6.2.5 version) portlet which can work on Liferay 5.2.3, but when we try to deploy the same portlet (changed configuration files) under Liferay 5.0.1 error happens: (below is the error message from Firefox vaadin debug window)

Vaadin application servlet version: 6.2.5
Widget set is built on version: 6.2.5
Application version: NONVERSIONED
inserting load indicator
Making UIDL Request with params: init
Server visit took 335ms

Communication error: (SyntaxError): missing ) in parenthetical fileName: http://localhost:8080/html/VAADIN/widgetsets/com.vaadin.portal.gwt.PortalDefaultWidgetSet/7A77340041A9878AF8784E8BBFFABE09.cache.html lineNumber: 1402 stack: eval(“( html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "\”>…

We looked into /html/VAADIN/widgetsets/com.vaadin.portal.gwt.PortalDefaultWidgetSet/7A77340041A9878AF8784E8BBFFABE09.cache.html file, and there is no ) missing.

When using Safari to debug, it showed another error, which is

Communication error: (SyntaxError): Parse error line: 1 sourceId: 4752244600 - Original JSON-text:…

We have modified ROOT/WEB-INF/classes/
added VAADIN folder under ROOT/html
added vaadin.jar (removed version text), under ROOT/WEB-INF/lib
changed portlet.xml, liferay-portlet.xml, liferay-plugin-package.properteis, liferay-display.xml

We tried to create Hello World portlet to test, and got the same error when use Liferay 5.0.1

Thank you

It looks like everything is fine until Vaadin does the first UIDL-request. This should return a JSON snippet but apparently returns an HTML page ("html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" " etc.). Evaluating HTML as javascript obviously fails. You should be able to see this if you look at what is received from the server (Firebug network/request monitor).

Are you using a 2.0 portlet? The UIDL URL is a generated resource URL so it should work out of the box unless there are some portlet 2.0 bugs in Liferay 5.0.1?

We use
as Servlet class,
and init-param portlet-class with

all the configuration files used are under Portlet 2.0 definition,
we thought there might be the problem related with Liferay 5.0.1, but we also saw from Vaadin features it said Vaadin can support Liferay 4.3 or later. Maybe this kind of problem has been encountered and resolved.

At least portlet 1.0 (com.vaadin.terminal.gwt.server.ApplicationPortlet) works in older Liferays. In that case you deploy both a portlet and a servlet. The application is started through the portlet but all other requests go directly to the servlet. Not sure if anybody has tested portlet 2.0 support on older Liferay versions.