Eclipse project error: Websocket protocol not supported


I use Mercurial as version control system.
My first Vaadin project was automatically created via Eclipse and everything worked fine.
Just created a new “Vaadin 7.0 Project” and everything was done.

However, in my repository I dont want any Eclipse specific files and decided after 6 months to clean my repository.
Hence, I removed the .settings dir, .classpath and .project file.
So, in my Repo theres just the plain project and everything worked fine before.
I used Tomcat 8 for deployment. So far so good, but…

Now I want to be able to check out and configure it as a Vaadin project.
Here are my steps

  1. Check out project via hg (Mercurial)

  2. Right Click on Project > Properties > Project Facets > Convert to faceted form

Facet / Version
Java 1.8
Dynamic Web Module 3.1
JavaScript 1.0
Vaadin Plug-in for Eclipse

3)Right Click on Project > Configure > Add Ivy dependency management

Right Click on ivy.xml > Add Ivy Library
(should be default settings)
→ Main Tab → Ivy File: ivy.xml
→ Settings Tab → Ivy settings path → ivysettings.xml

  1. Right Click on Project > Deployment assembly > Add > Java Build Path Entries > Ivy > Finish

And voilà! The configuration is done. The vaadin compiler requires an eclipse restart otherwise it does not recognize the project as a vaadin project :-(… but ok.

Tomcat starts without problems and loads the application. But, when I enter the website I get a
Warning: Websocket protocol not supported. Hence, my application does not work correct.

public class GamificationUI extends UI {

@WebServlet(value = "/*", asyncSupported = true)
@VaadinServletConfiguration(productionMode = false, ui = GamificationUI.class, widgetset = "master.gamification.widgetset.GamificationWidgetset")
public static class Servlet extends VaadinServlet {

[/code]PushMode is set to automatic and async support is set to true.

I use Tomcat (tried many versions) but still the same error.
I have had never problems with my project unless I “cleaned” my mercurial repository
… so… did I miss any steps? or any configuration?

Best regards