Could not load VAADIN/vaadinBootstrap.js in Tomcat 7 with HTTPS enabled

Hello,

starting with Vaadin 7.0.0.beta4 my Vaadin-based webapp responds with an error message like “Could not load VAADIN/vaadinBootstrap.js”
when running in Tomcat 7 with HTTPS enabled.

Vaading 7.0.0.beta3 has no such issues.

Do you have any Idea?

Thanks in advance.

Torsten

Hello,

I’m still stuck - The problem still exists with beta6 (see the attached screenshot).

Torsten
12615.png

This is most likely caused by changing the bootstrapping sequence use relative paths instead of absolute though I can’t still guess exactly what is wrong in your case.

Does your app work properly if using http instead of https?

Could you compare from where it tries to load vaadinBootstrap.js (e.g. using the Net tab in Firebug or Network in Chrome’s Developer Tools) with and without https to hopefully discover what causes the problem?

How is you app deployed? Do you use e.g. a URL rewrite, URL forward or proxy that might cause the paths to be messed up?

Hi there,

I also am facing same issue. with Vaadin 7 Glassfihs +3

What I am doing is pretty simple…Just following V7 Boook HelloWorld first steps. Created a brand new Java Web App using Netbeans 7.2. (Not using vaading plug in)

Web.xml

I still have problem starting the app…I notice that deployment takes TOO MUCH…! Dont’n know if that is Ok in V7

Any help will be appreciated…

Cheers,

Jose

Hello,

for me this problem vanished when I cleared my browser cache.

The problem occured maybe due to the fact that I used the same browser window for accessing various
web apps using different Vaadin versions.

So, thanks for Your help.

Torsten

Hi.
Does anyone have a solution to this? I am encountering the same error with vaadin 7. I checked that the vaadin-server.jar is part of the war file. i also tried extracting the vaadinBootstrap.js to the WEB-INF/classes/VAADIN folder. Also tried extracting it to /VAADIN folder. Any ideas? I have also tried clearing my browser cache. it didnt work.

thanks for your help!