Corrupted File Error

Hi,

I’m using Vaadin for a school project and I’m getting an error when I run the code that there is a corrupted file that will be deleted and redownloaded after I re-run the program, however, this isn’t happening and I keep getting the same error. Is there a way to fix this?

This is the error I get →
.vaadin/node-v16.15.0-darwin-arm64.tar.gz is corrupted and will be deleted. Please run the application again.

It would be helpful to know what version of Vaadin you are using and how you are building it. It doesn’t seem like this is a common problem (based on Google searches)–maybe something to do with your local version of Npm? Otherwise you might try following the recommendations in this link that indicates how to clean up the JavaScript parts of Vaadin which might help: https://mvysny.github.io/Vaadin-troubleshooting/

I got it working, thank you