BlackDuck Security Issue

I am getting blackduck high security issues with node-semver6.3.0 and node-semver7.5.1.
Which stable version should I add?

6.3.1 or 7.5.2 as described in the CVE.

Thanks

I am using vaadinVersion=23.2.16, which version should I need to upgrade to fix the above security issues ?