AppScale instead of Google AppEngine

I would like to host Vaadin applications using AppScale, that is an open-source framework for running Google AppEngine applications.

I succeeded in running application at Google AppEngine, but AppScale deployment failed :frowning: Is there anybody who has insight to the problem or has tried to do that? I created the project using Eclipse+plugin. I speculate that the problem may be that war/web-inf/lib contains some appengine-specific jar-files… I wonder if they should be replaced with somekind of AppScale counterparts. However, I do not like the idea, that the project needs to be altered :frowning:

Hi there! I’m a lead developer on the AppScale project - maybe I can give you a helping hand :slight_smile:

You shouldn’t have to change your app at all to run on AppScale, but I do have a few questions for you:

  • How did you start up AppScale? Are you running in EC2, Eucalyptus, or over a virtualized cluster?
  • How did you deploy your application? When you run “appscale deploy your-app”, what did it say?

On the last question, that should pin down why your app isn’t getting uploaded. Let us know what it reports back and we should be able to get your app running on AppScale!

Hello and thanks for your quick answer.

We are running AppScale on top of OpenStack that runs on top of Ubuntu.

I think we had something wrong with AppScale, since the any of the applications that previously worked did not run anymore:( However, we re-installed AppScale and after that our GAE-Vaadin example software worked perfectly.

So problem is solved.

Great, glad to hear it all worked out for you! We’d love to have you blog about it on the AppScale blog - how you got it to work on OpenStack, and what you use AppScale for, if that works by you.

Feel free to send me an e-mail at chris@appscale.com and we can get it all figured out :slight_smile: