appfoundation internationalization problem

I’m using the code bit below and s comes out empty, what am I doing wrong?


public class ReallotoApplication extends Application
...
Lang.initialize(ReallotoApplication.this);
Lang.setLocale(Locale.ENGLISH);
String s = Lang.getLocale().getCountry();
System.out.println(s);

Multiple things can be wrong. Have you registered the InternationalizationServlet? Do you have a translations file? Have you loaded the translation file into the i18n servlet? Read
this example
, follow the instructions and use the code examples.

Seems the problem is that I’m suppose to getLanguage() instead of getCountry(), and from the short doc I misunderstood.
Lang.ENGLISH for instance is a static Locale that has only the language set.


Although the country is set, it comes out the other end empty for some reason

My problem is kind of solved, dunno what’s up with that…

The problem arose when I used this:

InternationalizationServlet.getMessage("en","WELCOME_MESSAGE","John Doe","today at 12:20 pm");

and I tried to use Lang.getLocale().getCountry() instead of “en”, when I should’ve used Lang.getMessage() instead.
11794.jpg