Add-on Not Working

I am using Vaadin to make portlets for liferay and it’s been working great. I am using the “Tree Table” Add-on for a specific widget.

For it to work I had to download the add-on file, compile the widget set, etc. I got this to work great.

Today, I have made a fresh install of liferay, and figured I would update Vaadin. I was running 6.5.0 and I’ve upgraded to 6.5.2, I downloaded the update, copied “themes” and “widgetsets” dirs to /var/lib/tomcat6/webapps/ROOT/html/VAADIN/

I have also copied the new vaadin-6.5.2.jar file to …/ROOT/WEB-INF/lib and renamed it to vaadin.jar. I moved all my portlet and hook directories to my Webapps dir.

In eclipse if I go to the Properties of my project, I can see that my Vaadin Version is correct (6.5.2), however I deploy my war file, upload it to my liferay instance and I get this:

Widgetset does not contain implementation for com.vaadin.addon.treetable.TreeTable. Check its @ClientWidget mapping, widgetsets GWT module description file and re-compile your widgetset. In case you have downloaded a vaadin add-on package, you might want to refer to add-on instructions. Unrendered UIDL:

	com.vaadin.addon.treetable.TreeTable(NO CLIENT IMPLEMENTATION FOUND)

I have copied over the gwt/ directories to /var/lib/tomcat6/webapps/ROOT/WEB-INF/vaadin/gwt/

I have tried adding ?debug to the URL and I see this in my log (not sure if this is the problem or if its even related):

Warning: your widget set seems to be built with a different version than the one used on server. Unexpected behavior may occur.

What could I be doing wrong? Any advice would be a huge help, thanks!

Did you recompile the widgetset after switching the vaadin jar? When you compile a widgetset it takes all the vaadin core component’s AND the add-ons client side and compiles it to one set of js/html files. This means that if you don’t recompile, you’ll have the client side of Vaadin 6.5.0 and the server side of 6.5.2. If you remove the compiled widgetset, Vaadin will use the widgetset it has inside the vaadin jar, and the version numbers will match, but the add-ons client side won’t be in there.

Thank you for the response, I have used the Vaadin Control Panel to compile the widgetset, I have removed both plugins and readded them, then use the Vaadin Control Panel to recompile the widgetset.

5 permutations finish and get a message Completed Successfully, but it still says the same error.

it actually ended up being a permission issue thanks!

Hi,
I am using vaadin to create portlets in liferay and I need to use the TreeTable add-on to display components in a tree structure.
When I deploy the war file and add an instance of the application to the portal, I get this:

Any help would be appreciated.
Thanks in advance!!

The problem I was having was with permissions, it may or may not be the case with you,

if your on linux go to the directory where your jars are kept and make sure the widget in question has the same owner and octal permissions as the other jars that are currently working,

Otherwise, assuming your using liferay, make sure you have compiled the widgetset using the vaadin control panel and make sure all 5 permutations complete before closing the page,

I hope this helps!

Thanks for your help. It was very useful. :slight_smile:
I am new to both vaadin and liferay. I didn’t know that I had to compile widgetset using vaadin control pannel.
I installed the vaadin control pannel portlet and compiled widgetset. But it doesn’t get compiled.
I have attached a screenshot of it.

I’m getting the following exception. I think it should be something wrong with the PortalDefaultWidgetSet but I can not figure it out.

Inside html/VAADIN/widgetsets folder there’s a folder named com.vaadin.portal.gwt.PortalDefaultWidgetSet
I’m not sure whether the content of that folder is correct.
Any idea how I should over come this issue?

Thanks.
11624.png