23.3.2 -> 23.3.4 lit version mismatches

Hey all,
as the title says, Vite starts complaining after the recent update.
e
@vaadin/bundles has version mismatches with installed packages, Vaadin component dependency bundles are disabled.
ePackages with version mismatches: [
e {
e “name”: “lit”,
e “bundledVersion”: “2.6.1”,
e “installedVersion”: “2.4.1”
e }
]

Nevertheless the application is starting…
Anyone has noticed that, too?

Cheers
Mojo

Try cleaning out the frontend files and re-running the build

Hmm
I did mvn vaadin:clean-frontend and also mvn vaadin:dance

All the same - in all of my 3 projects. :man_shrugging:

Edit: just tried again with same result.
The generated package.json contains “lit”: “2.4.1”,

If you at some point have set it manually then it won’t be auto-updated

so does it contain “2.4.1” even if you remove package.json or remove the row at least

Haven’t touched the package.json, and it is an empty structure after vaadin:clean-frontend.
After spring-boot:run when dependencies get added to package.json that row with lit 2.4.1 appears.

Thanks, there seems to be a problem with the release itself

I might try later with a fresh project from start.vaadin.com as my projects are already in development since flow 23.0 IIRC

It reproduces in a fresh project

The Flow version included is too old

ah ok