Compatibility

Vaadin is designed to be a one-stop solution to create web UIs, but you can also use some of its parts in isolation.

For the best effect, we recommend that you combine Vaadin with a well-documented Java backend framework such as Spring or JavaEE/CDI. With these combinations, Vaadin can provide everything you need for fully featured web applications.

CategoryProducts

JDK

Java 8 or later; OpenJDK, Amazon Corretto, Oracle JDK

JVM Languages

Java, Groovy, Kotlin, etc.

Java Frameworks

Spring, JavaEE/CDI, etc.

IDEs

Eclipse IDE, NetBeans IDE, IntelliJ IDEA, VS Code, Atom, etc.

Servlet Containers

Apache Tomcat, Apache TomEE, WildFly, GlassFish, JBoss, Jetty, etc.

Server-Side Build Management

Maven (3.5 or newer) or Gradle (6 or newer)

Client-Side Build Management

Node (10 or newer) / npm (5.6 or newer)

Browsers

Chrome, Firefox, Edge, Safari

For a particular version of the Vaadin, see the release notes for a more comprehensive list of supported technologies.

On the client-side, any Vaadin component can be used independently without the full framework. Dependencies are managed through npm. In addition, Vaadin Router works well on its own, and can be used in lightweight client-side applications.