You are viewing documentation for Vaadin Framework 8 and related products View documentation for Vaadin Framework 7 ›
Installing in Eclipse · Vaadin
Vaadin Designer - Installing in Eclipse
 Edit This Page

Installing in Eclipse

Installing Eclipse and Plug-Ins

You need to install the following to use Vaadin Designer:

  1. Eclipse Luna SR2+ as described in Installing Eclipse IDE

  2. Vaadin Plug-in for Eclipse as described in Installing Vaadin Plugin for Eclipse

  3. Vaadin Designer from vaadin.com/eclipse

Vaadin Designer is compatible with Eclipse Luna (and later) available from www.eclipse.org/downloads. We recommend choosing Eclipse IDE for Java EE Developers.

If you’re using an existing install of Eclipse Luna, please make sure it is up-to-date. Eclipse Luna versions prior to the SR2 version had a nasty bug that will cause problems for several plug-ins.

Vaadin Designer is installed together with the Vaadin Plug-in for Eclipse, from the same Eclipse update-site. In Eclipse, do Help ▸ Install New Software, press Add…​ next to the Work with select, enter Vaadin as name and http://vaadin.com/eclipse as location.

If you already have the Vaadin plug-in installed, just choose to Work with the Vaadin update site. Make sure the whole Vaadin category is selected (or at least Vaadin Designer), then click Next to review licensing information and finalize the install. Please restart Eclipse when prompted.

Once installed, Vaadin Designer can be kept up-to-date by periodically running Help ▸ Check for Updates.

Uninstalling

If you want to remove Vaadin Designer from your Eclipse installation, go to Help ▸ Installation Details, select Vaadin Designer from the list, then click Uninstall.