Directory

← Back

Viritin-Compatbility-Jakarta

Additional Vaadin 7 compatibility library for Virtitin Jakarta for Vaadin 8

Author

Rating

Popularity

<100

This add-on contains helper for Viritin Jakarta users who are upgrading to Vaadin 8 and want to do that with minimal effort. The package contains all old components and helpers that require vaadin-compatibility-server package.

To use them, you'll need to replace all package names so that for example MTextField compatible with v7 stuff is imported from org.vaadin.viritinv7.fields instead of org.vaadin.viritin.fields.

Note, although this artifact is Apache 2 licensed, it requires to use Vaadin 8.18 or newer, which is requiring Vaadin 8 Extended Maintenance subscription, see more https://vaadin.com/vaadin-8-extended-maintenance

Compatibility

2.14.4
(24.3)
(24.2)
(24.1)
(24)
(23)
(22)
(21)
(20)
(19)
(18)
(17)
(16)
(15)
(14)
(13)
(12)
(11)
(10)
8.18-8.21Y
(8.17)
(8.16)
(8.15)
(8.14)
(8.13)
(8.12)
(8.11)
(8.10)
(8.9)
(8.8)
(8.7)
(8.6)
(8.5)
(8.4)
(8.3)
(8.2)
(8.1)
(8.0)
(7.7)
(7.6)
(7.5)
(7.4)
(7.3)
(7.2)
(7.1)
(7.0)
(6.8)
(6.7)
(6.6)
(6.5)
(6.4)
(6.3)
(6.2)
(6.1)
(6.0)

Was this helpful? Need more help?
Leave a comment or a question below. You can also join the chat on Discord or ask questions on StackOverflow.

Version

Version 2.14.4

  • The same features as with Viritin 2.14.1
Released
2024-02-22
Maturity
BETA
License
Apache License 2.0

Compatibility

Framework
Vaadin 8.18+
Browser
Firefox
Opera
Safari
Google Chrome
Microsoft Edge

Viritin-Compatbility-Jakarta - Vaadin Add-on Directory

Additional Vaadin 7 compatibility library for Virtitin Jakarta for Vaadin 8 Viritin-Compatbility-Jakarta - Vaadin Add-on Directory
This add-on contains helper for Viritin Jakarta users who are upgrading to Vaadin 8 and want to do that with minimal effort. The package contains all old components and helpers that require vaadin-compatibility-server package. To use them, you'll need to replace all package names so that for example MTextField compatible with v7 stuff is imported from org.vaadin.viritinv7.fields instead of org.vaadin.viritin.fields. Note, although this artifact is Apache 2 licensed, it requires to use Vaadin 8.18 or newer, which is requiring Vaadin 8 Extended Maintenance subscription, see more https://vaadin.com/vaadin-8-extended-maintenance
Online